Welcome to the BillionGraves Community! An amazing community of users from every corner of the globe here to help you in your BillionGraves endeavors! Join the movement and connect with others to create the world's largest GPS cemetery database!
Welcome to BillionGraves Q&A, where you can ask questions, receive support, and look at answers from other members of the BillionGraves community.

3.2k questions

4.2k answers


2.8k users

1 like 0 dislike
When I click on SAVE, I am not getting a summary of the completed record.  Instead when I click on SKIP, I'm getting a message saying that the record was not saved! Can anyone please help me here? Thx.
asked in Saving by aussiebushgirl BG Beginner (130 points)

2 Answers

0 like 0 dislike
Did this resolve for you?

Anytime you have data in the entry fields and you hit SKIP (intentionally or in my case usually accidentally) it will popup the message to ask if you really mean to skip the entry.

I just did a couple of transcriptions and everything seems to be working for me.

When you click on SAVE, do you get a NEXT button showing up, or does it just stick so your only option is to SKIP? Is this a consistent problem, no matter what image you try?

You might try just logging out and logging back in. Sometimes that will clear up something in your machine that is causing the glitch.

answered by dswright BG Master (37.7k points)
Hi and thanks. No it has not resolved. I've just logged back in for the first time since I put out a message for help, with the exact same result. It simply sticks on SAVE, so my only option is to SKIP. (The record I have completed today is a very big one, which will now be lost. So sad.)
Can you login on a different machine and see if it works with your login on a different device?

What browser/device combination are you using? BG is explicit that one should not try to transcribe on smartphones and small tablets, as the OS does not support the main interface.

 If you are trying to do this on a small machine it is very glitchy. Be sure you are using a full laptop or regular desktop computer.

If this does not help you need to send a request to BG Support, and be sure to give them the URL for this conversation and also: the device and browser and OS you are trying to use. They need as much info as you can give them so they can try to recreate the issue and then try to resolve it for you.

Hi DS. Thank you so much for your help so far. Much appreciated.

I use an Apple MacBook Pro using OSX via Firefox, and don't have access to any other device, except for my Apple iPad which is unsuitable for this process. The problem I am experiencing when SAVING, continues. I have just sent a request to BG Support, following on from previous requests for help with the same problem. Unfortunately, they have only sent a generic response email in the past, with no real feedback or help. I'm hoping my new request will go the distance!

heather (aussiebushgirl)
Have your tried a differnent version of a browser, such as Chrome?Macs so don't know what would be best on that platform.  I use a PC - Dell laptop with Chrome and have very few interface problems. Maybe someone here with Mac experience has a few words of advice.


0 like 0 dislike
I have the same problem, however I those that I get that can't be saved do not have a cemetery link. When I save it just sits there. Most of mine are from Dazza who when uploading pictures they have not supplied the cemetery name.
answered by Wayne BG Beginner (180 points)